Yii2 第27章 composer安装Yii2版本冲突 Yii2 第27章 composer安装Yii2版本冲突

2023-03-04

composer 安装 Yii2 版本冲突

composer create-project --prefer-dist yiisoft/yii2-app-advanced advanced

在运行 composer 安装 Yii2 高级版本时会报下面错误

 Problem 1
    - Root composer.json requires codeception/module-filesystem ^3.0 || ^1.1 -> satisfiable by codeception/module-filesystem[3.0.0].
    - codeception/module-filesystem 3.0.0 requires php ^8.0 -> your php version (7.4.29) does not satisfy that requirement.

这个主要问题是 php 版本冲突,我安装的是 php7.4,需要 php8.0

只需要在后面加上--ignore-platform-reqs

composer create-project --prefer-dist yiisoft/yii2-app-advanced advanced --ignore-platform-reqs

安装 Yii2 插件时也可以加上,比如安装 Execl 的插件 phpspreadsheet

composer require phpoffice/phpspreadsheet --ignore-platform-reqs
阅读 369